aboutsummaryrefslogtreecommitdiffstats
path: root/libparc/parc/testing/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara+fdio@cisco.com>2018-12-18 11:05:49 +0000
committerGerrit Code Review <gerrit@fd.io>2018-12-18 11:05:49 +0000
commitcada1143501a48effc483e3873596c22849926b5 (patch)
tree93a1da95d69b69328a1e7d3621447797f65137c9 /libparc/parc/testing/test/CMakeLists.txt
parent726949d76a7207694d5a1eee84ef134a8e539115 (diff)
parenta45edf23c2463ac9a4723a24792a6c5c89b1e021 (diff)
Merge "Adding gitreview config file for this branch sub project"
Diffstat (limited to 'libparc/parc/testing/test/CMakeLists.txt')
-rw-r--r--libparc/parc/testing/test/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/libparc/parc/testing/test/CMakeLists.txt b/libparc/parc/testing/test/CMakeLists.txt
new file mode 100644
index 00000000..1de2e89d
--- /dev/null
+++ b/libparc/parc/testing/test/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(TestsExpectedToPass
+ test_parc_MemoryTesting
+ test_parc_ObjectTesting
+ )
+
+# Enable gcov output for the tests
+add_definitions(--coverage)
+set(CMAKE_EXE_LINKER_FLAGS ${CMAKE_EXE_LINKER_FLAGS} " --coverage")
+
+foreach(test ${TestsExpectedToPass})
+ AddTest(${test})
+endforeach()