aboutsummaryrefslogtreecommitdiffstats
path: root/longbow/documentation/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara+fdio@cisco.com>2017-04-29 04:30:05 +0200
committerMauro Sardara <msardara+fdio@cisco.com>2017-04-29 12:32:47 +0000
commit8dab1436b701372eacf32bd6e22b452c486af01e (patch)
tree77cdc3f9bdff4275f98c1d9c0309ec1a903372cb /longbow/documentation/CMakeLists.txt
parent90810dee44fec032a253a379bdd46e1198274fff (diff)
Adding support for building dev and doc packages.
Change-Id: I0631bbf72e23e8f03645f300f2b89980e91da6ec Signed-off-by: Mauro Sardara <msardara+fdio@cisco.com>
Diffstat (limited to 'longbow/documentation/CMakeLists.txt')
-rw-r--r--longbow/documentation/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/longbow/documentation/CMakeLists.txt b/longbow/documentation/CMakeLists.txt
index 33f92995..61e9f8b6 100644
--- a/longbow/documentation/CMakeLists.txt
+++ b/longbow/documentation/CMakeLists.txt
@@ -5,10 +5,10 @@ if(DOXYGEN_FOUND)
set(GITHUB_REMOTE http://github.com/PARC/LongBow)
configure_file(longbow.doxygen.in config.doxygen @ONLY)
- install(DIRECTORY images/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/images)
- install(DIRECTORY doxygen-extras/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/doxygen-extras)
- install(DIRECTORY examples/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/examples)
- install(FILES DoxygenLayout.xml DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow)
+ install(DIRECTORY images/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/images COMPONENT documentation)
+ install(DIRECTORY doxygen-extras/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/doxygen-extras COMPONENT documentation)
+ install(DIRECTORY examples/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/examples COMPONENT documentation)
+ install(FILES DoxygenLayout.xml DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow COMPONENT documentation)
set(HTML_PATH ${CMAKE_CURRENT_BINARY_DIR}/generated-documentation/html)