aboutsummaryrefslogtreecommitdiffstats
path: root/longbow/src/LongBow/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara+fdio@cisco.com>2017-04-29 04:30:05 +0200
committerMauro Sardara <msardara+fdio@cisco.com>2017-04-29 12:32:47 +0000
commit8dab1436b701372eacf32bd6e22b452c486af01e (patch)
tree77cdc3f9bdff4275f98c1d9c0309ec1a903372cb /longbow/src/LongBow/CMakeLists.txt
parent90810dee44fec032a253a379bdd46e1198274fff (diff)
Adding support for building dev and doc packages.
Change-Id: I0631bbf72e23e8f03645f300f2b89980e91da6ec Signed-off-by: Mauro Sardara <msardara+fdio@cisco.com>
Diffstat (limited to 'longbow/src/LongBow/CMakeLists.txt')
-rw-r--r--longbow/src/LongBow/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/longbow/src/LongBow/CMakeLists.txt b/longbow/src/LongBow/CMakeLists.txt
index 476cc8ab..27efc12c 100644
--- a/longbow/src/LongBow/CMakeLists.txt
+++ b/longbow/src/LongBow/CMakeLists.txt
@@ -157,11 +157,11 @@ set(longbowLibraries
)
foreach(lib ${longbowLibraries})
- install(TARGETS ${lib} LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
+ install(TARGETS ${lib} COMPONENT library LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
endforeach()
-install(FILES ${LIBLONGBOW_HEADER_FILES} DESTINATION include/LongBow )
-install(FILES ${LONGBOW_REPORT_HEADER_FILES} DESTINATION include/LongBow/Reporting )
+install(FILES ${LIBLONGBOW_HEADER_FILES} DESTINATION include/LongBow COMPONENT headers)
+install(FILES ${LONGBOW_REPORT_HEADER_FILES} DESTINATION include/LongBow/Reporting COMPONENT headers)
if(ANDROID_API)
message("############ Detected cross compile for ${CMAKE_SYSTEM_NAME}")