aboutsummaryrefslogtreecommitdiffstats
path: root/longbow/src/LongBow/test/CMakeLists.txt
diff options
context:
space:
mode:
authorLuca Muscariello <lumuscar+fdio@cisco.com>2017-02-23 17:01:02 +0100
committerLuca Muscariello <lumuscar+fdio@cisco.com>2017-02-23 17:21:02 +0100
commitec688b4723a041044226358bcd4dd6e2da39da49 (patch)
tree3a244c48d1eb9e4d90f9050fd1a61ae5c0327526 /longbow/src/LongBow/test/CMakeLists.txt
parent9b30fc10fb1cbebe651e5a107e8ca5b24de54675 (diff)
Initial commit: cframework. Longbow and Libparc
Change-Id: I90378dbd30da6033b20fb1f829b3b822cf366c59 Signed-off-by: Luca Muscariello <lumuscar+fdio@cisco.com>
Diffstat (limited to 'longbow/src/LongBow/test/CMakeLists.txt')
-rw-r--r--longbow/src/LongBow/test/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/longbow/src/LongBow/test/CMakeLists.txt b/longbow/src/LongBow/test/CMakeLists.txt
new file mode 100644
index 00000000..5eba0444
--- /dev/null
+++ b/longbow/src/LongBow/test/CMakeLists.txt
@@ -0,0 +1,52 @@
+# Enable gcov output for the tests
+add_definitions(--coverage)
+set(CMAKE_EXE_LINKER_FLAGS ${CMAKE_EXE_LINKER_FLAGS} " --coverage")
+
+
+macro(AddTest testFile)
+ add_executable(${ARGV0} ${ARGV0}.c)
+ target_link_libraries(${ARGV0} longbow longbow-ansiterm)
+ add_test(${ARGV0} ${ARGV0})
+ set_target_properties(${ARGV0} PROPERTIES FOLDER Test)
+endmacro(AddTest)
+
+set(TestsExpectedToFail
+ test_longBow_Expected;
+)
+
+# test_assertions;
+
+set(TestsExpectedToPass
+ test_MemoryLeaks;
+ test_longBow_ArrayList;
+ test_longBow_Config;
+ test_longBow_Fixture;
+ test_longBow_Memory;
+ test_longBow_Location;
+ test_fixtureConfiguration;
+ test_longBow_Backtrace;
+ test_longBow_CommandLineOptions;
+ test_longBow_Debug;
+ test_longBow_Main;
+ test_longBow_MeasureTime;
+ test_longBow_OpenFile;
+ test_longBow_Properties;
+ test_longBow_Runner;
+ test_longBow_Runtime;
+ test_longBow_Status;
+ test_longBow_String;
+ test_longBow_TestCase;
+ test_longBow_TestCaseClipBoard;
+ test_longBow_UnitTesting
+ )
+
+foreach(test ${TestsExpectedToPass})
+ AddTest(${test})
+endforeach()
+
+foreach(test ${TestsExpectedToFail})
+ AddTest(${test})
+ set_tests_properties(${test} PROPERTIES WILL_FAIL TRUE)
+endforeach()
+
+