aboutsummaryrefslogtreecommitdiffstats
path: root/longbow/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara+fdio@cisco.com>2017-04-29 04:30:05 +0200
committerMauro Sardara <msardara+fdio@cisco.com>2017-04-29 12:32:47 +0000
commit8dab1436b701372eacf32bd6e22b452c486af01e (patch)
tree77cdc3f9bdff4275f98c1d9c0309ec1a903372cb /longbow/src/python/CMakeLists.txt
parent90810dee44fec032a253a379bdd46e1198274fff (diff)
Adding support for building dev and doc packages.
Change-Id: I0631bbf72e23e8f03645f300f2b89980e91da6ec Signed-off-by: Mauro Sardara <msardara+fdio@cisco.com>
Diffstat (limited to 'longbow/src/python/CMakeLists.txt')
-rw-r--r--longbow/src/python/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/longbow/src/python/CMakeLists.txt b/longbow/src/python/CMakeLists.txt
index 157cda21..33e2d70e 100644
--- a/longbow/src/python/CMakeLists.txt
+++ b/longbow/src/python/CMakeLists.txt
@@ -1,10 +1,10 @@
-add_subdirectory(site-packages)
+add_subdirectory(site-packages)
install( FILES parc_uncrustify.cfg DESTINATION ${CMAKE_INSTALL_PREFIX}/etc )
macro(AddLongBowPythonScript scriptFile)
configure_file(${ARGV0}.py ${ARGV0} @ONLY)
- install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${ARGV0} DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${ARGV0} COMPONENT library DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
endmacro(AddLongBowPythonScript)
set(ScriptList