aboutsummaryrefslogtreecommitdiffstats
path: root/longbow/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authorLuca Muscariello <lumuscar+fdio@cisco.com>2017-02-23 17:01:02 +0100
committerLuca Muscariello <lumuscar+fdio@cisco.com>2017-02-23 17:21:02 +0100
commitec688b4723a041044226358bcd4dd6e2da39da49 (patch)
tree3a244c48d1eb9e4d90f9050fd1a61ae5c0327526 /longbow/src/python/CMakeLists.txt
parent9b30fc10fb1cbebe651e5a107e8ca5b24de54675 (diff)
Initial commit: cframework. Longbow and Libparc
Change-Id: I90378dbd30da6033b20fb1f829b3b822cf366c59 Signed-off-by: Luca Muscariello <lumuscar+fdio@cisco.com>
Diffstat (limited to 'longbow/src/python/CMakeLists.txt')
-rw-r--r--longbow/src/python/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/longbow/src/python/CMakeLists.txt b/longbow/src/python/CMakeLists.txt
new file mode 100644
index 00000000..157cda21
--- /dev/null
+++ b/longbow/src/python/CMakeLists.txt
@@ -0,0 +1,29 @@
+add_subdirectory(site-packages)
+
+install( FILES parc_uncrustify.cfg DESTINATION ${CMAKE_INSTALL_PREFIX}/etc )
+
+macro(AddLongBowPythonScript scriptFile)
+ configure_file(${ARGV0}.py ${ARGV0} @ONLY)
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${ARGV0} DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
+endmacro(AddLongBowPythonScript)
+
+set(ScriptList
+ longbow-doxygen-report
+ longbow-generate-about
+ longbow-preprocess
+ longbow-code
+ longbow-complexity-report
+ longbow-coverage-report
+ longbow-bytearray
+ longbow-ansigcov
+ longbow-name-report
+ longbow-size-report
+ longbow-style-report
+ longbow-test-run
+ longbow-test-suite
+ longbow-vocabulary-report
+ )
+
+foreach(script ${ScriptList})
+ AddLongBowPythonScript(${script})
+endforeach()