aboutsummaryrefslogtreecommitdiffstats
path: root/IGetAndroid/app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'IGetAndroid/app/CMakeLists.txt')
-rw-r--r--IGetAndroid/app/CMakeLists.txt83
1 files changed, 83 insertions, 0 deletions
diff --git a/IGetAndroid/app/CMakeLists.txt b/IGetAndroid/app/CMakeLists.txt
new file mode 100644
index 00000000..95019c1d
--- /dev/null
+++ b/IGetAndroid/app/CMakeLists.txt
@@ -0,0 +1,83 @@
+# For more information about using CMake with Android Studio, read the
+# documentation: https://d.android.com/studio/projects/add-native-code.html
+
+# Sets the minimum version of CMake required to build the native library.
+
+cmake_minimum_required(VERSION 3.4.1)
+
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
+set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+
+set(CMAKE_FIND_ROOT_PATH "$ENV{DISTILLERY_ROOT_DIR}/usr_${CMAKE_SYSTEM_PROCESSOR};${CMAKE_FIND_ROOT_PATH}")
+include_directories(${PROJECT_SOURCE_DIR})
+
+
+find_package(Boost 1.53.0 COMPONENTS system REQUIRED)
+include_directories(SYSTEM ${Boost_INCLUDE_DIR})
+
+include_directories($ENV{CCNX_DEPENDENCIES}/include)
+set(OPENSSL_ROOT_DIR $ENV{CCNX_DEPENDENCIES})
+
+find_package( LongBow REQUIRED )
+include_directories(${LONGBOW_INCLUDE_DIRS})
+
+find_package( LibEvent REQUIRED )
+include_directories(${LIBEVENT_INCLUDE_DIRS})
+
+find_package( Libparc REQUIRED )
+include_directories(${LIBPARC_INCLUDE_DIRS})
+
+find_package( CCNX_Common REQUIRED )
+include_directories(${CCNX_COMMON_INCLUDE_DIRS})
+
+find_package( CCNX_Transport_Rta REQUIRED )
+include_directories(${CCNX_TRANSPORT_RTA_INCLUDE_DIRS})
+
+find_package( CCNX_Portal REQUIRED )
+include_directories(${CCNX_PORTAL_INCLUDE_DIRS})
+
+find_package ( Threads REQUIRED )
+
+find_package(Libicnet REQUIRED)
+include_directories(${LIBICNET_INCLUDE_DIRS})
+
+find_package ( OpenSSL REQUIRED )
+
+
+# Creates and names a library, sets it as either STATIC
+# or SHARED, and provides the relative paths to its source code.
+# You can define multiple libraries, and CMake builds them for you.
+# Gradle automatically packages shared libraries with your APK.
+
+add_library( # Sets the name of the library.
+ IGetWrapper
+
+ # Sets the library as a shared library.
+ SHARED
+
+ # Provides a relative path to your source file(s).
+ src/main/cpp/IGetWrapper.cpp )
+
+# Searches for a specified prebuilt library and stores the path as a
+# variable. Because CMake includes system libraries in the search path by
+# default, you only need to specify the name of the public NDK library
+# you want to add. CMake verifies that the library exists before
+# completing its build.
+
+find_library( # Sets the name of the path variable.
+ log-lib
+
+ # Specifies the name of the NDK library that
+ # you want CMake to locate.
+ log )
+
+# Specifies libraries CMake should link to your target library. You
+# can link multiple libraries, such as libraries you define in this
+# build script, prebuilt third-party libraries, or system libraries.
+
+target_link_libraries( # Specifies the target library.
+ IGetWrapper
+
+ # Links the target library to the log library
+ # included in the NDK.
+ ${log-lib} ${LIBICNET_LIBRARIES} ${Boost_LIBRARIES} ${CCNX_PORTAL_LIBRARIES} ${CCNX_TRANSPORT_RTA_LIBRARIES} ${CCNX_COMMON_LIBRARIES} ${LIBPARC_LIBRARIES} ${LONGBOW_LIBRARIES} ${LIBEVENT_LIBRARIES} ${OPENSSL_LIBRARIES})