aboutsummaryrefslogtreecommitdiffstats
path: root/libparc/documentation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libparc/documentation/Makefile.am')
-rw-r--r--libparc/documentation/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/libparc/documentation/Makefile.am b/libparc/documentation/Makefile.am
new file mode 100644
index 00000000..4163756c
--- /dev/null
+++ b/libparc/documentation/Makefile.am
@@ -0,0 +1,30 @@
+# Copyright (c) 2017 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+include ../config.mk
+
+docs: doxygen-libparc
+
+doxygen-libparc: libparc.doxygen
+
+ ${DOXYGEN_BIN} -s libparc.doxygen
+ ${prefix}/bin/longbow-doxygen-report -a --doxygenlog libparc-doxygen.log
+
+website: libparc-doxygen.log
+ $(MAKE) -C Jekyll
+
+# The Doxygen output directory removed here is set in libparc.doxygen
+clobber: clean
+ ${RM} -rf libparc-documentation
+
+CLEANFILES=libparc-doxygen.log libparc.doctags