aboutsummaryrefslogtreecommitdiffstats
path: root/longbow/src/python/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'longbow/src/python/CMakeLists.txt')
-rw-r--r--longbow/src/python/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/longbow/src/python/CMakeLists.txt b/longbow/src/python/CMakeLists.txt
new file mode 100644
index 00000000..33e2d70e
--- /dev/null
+++ b/longbow/src/python/CMakeLists.txt
@@ -0,0 +1,29 @@
+add_subdirectory(site-packages)
+
+install( FILES parc_uncrustify.cfg DESTINATION ${CMAKE_INSTALL_PREFIX}/etc )
+
+macro(AddLongBowPythonScript scriptFile)
+ configure_file(${ARGV0}.py ${ARGV0} @ONLY)
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${ARGV0} COMPONENT library DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
+endmacro(AddLongBowPythonScript)
+
+set(ScriptList
+ longbow-doxygen-report
+ longbow-generate-about
+ longbow-preprocess
+ longbow-code
+ longbow-complexity-report
+ longbow-coverage-report
+ longbow-bytearray
+ longbow-ansigcov
+ longbow-name-report
+ longbow-size-report
+ longbow-style-report
+ longbow-test-run
+ longbow-test-suite
+ longbow-vocabulary-report
+ )
+
+foreach(script ${ScriptList})
+ AddLongBowPythonScript(${script})
+endforeach()