aboutsummaryrefslogtreecommitdiffstats
path: root/PyPI/MLRsearch/setup.py
diff options
context:
space:
mode:
authorVratko Polak <vrpolak@cisco.com>2018-05-28 11:53:45 +0200
committerVratko Polak <vrpolak@cisco.com>2018-06-18 12:20:18 +0200
commita9f251c649a5dea7428a43dc24380077a72dacba (patch)
treee56e2cae2970968efe5f5ca285feb9f3b8ce2bbc /PyPI/MLRsearch/setup.py
parent938a0c9cec6d2177e098653ad398372fb482c36f (diff)
CSIT-986: Implement proposed MDR improvements
+ Use first intermediate with goal in initial phase. + Measure above MRR if that got zero loss. + Always prioritizes NDR in internal search. + Rename classes. + Copy code for standalone PyPI publishing. - Original files will be deleted after publish. Change-Id: I5169d602d1e5e35a1894645cd52e70d791871608 Signed-off-by: Vratko Polak <vrpolak@cisco.com>
Diffstat (limited to 'PyPI/MLRsearch/setup.py')
-rw-r--r--PyPI/MLRsearch/setup.py52
1 files changed, 52 insertions, 0 deletions
diff --git a/PyPI/MLRsearch/setup.py b/PyPI/MLRsearch/setup.py
new file mode 100644
index 0000000000..2411f4765a
--- /dev/null
+++ b/PyPI/MLRsearch/setup.py
@@ -0,0 +1,52 @@
+"""A setup module for setuptools.
+
+See:
+https://packaging.python.org/en/latest/distributing.html
+"""
+
+from setuptools import setup, find_packages
+from os import path
+from io import open
+
+here = path.abspath(path.dirname(__file__))
+with open(path.join(here, "README.rst"), encoding="utf-8") as f:
+ long_description = f.read()
+
+setup(
+ name="MLRsearch",
+ version="0.1.1", # This is currently the only place listing the version.
+ description="Library for speeding up binary search using shorter measurements.",
+ long_description=long_description,
+ long_description_content_type="text/x-rst",
+ # TODO: Create a separate webpage for MLRsearch library.
+ url="https://gerrit.fd.io/r/gitweb?p=csit.git;a=tree;f=PyPI/MLRsearch;hb=refs/heads/master",
+ author="Cisco Systems Inc. and/or its affiliates",
+ author_email="csit-dev@lists.fd.io",
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Science/Research",
+ "Intended Audience :: Telecommunications Industry",
+ # Pick your license as you wish
+ "License :: OSI Approved :: Apache Software License",
+ # TODO: Test which Python versions is the code compatible with.
+ "Programming Language :: Python :: 2.7",
+ "Topic :: System :: Networking"
+ ],
+ keywords="binary search throughput networking",
+ packages=find_packages(exclude=[]),
+ # TODO: python_requires="~=2.7"
+ install_requires=[],
+ # TODO: Include simulator and tests.
+ extras_require={
+ },
+ package_data={
+ },
+ entry_points={
+ "console_scripts": [
+ ],
+ },
+ project_urls={
+ "Bug Reports": "https://jira.fd.io/projects/CSIT/issues",
+ "Source": "https://gerrit.fd.io/r/gitweb?p=csit.git;a=tree;f=PyPI/MLRsearch;hb=refs/heads/master",
+ },
+)