aboutsummaryrefslogtreecommitdiffstats
path: root/PyPI/jumpavg/setup.py
diff options
context:
space:
mode:
authorVratko Polak <vrpolak@cisco.com>2018-06-14 14:04:03 +0200
committerTibor Frank <tifrank@cisco.com>2018-06-15 10:44:11 +0000
commit6149ec451efff00068f38e3343e66cdec7b943f4 (patch)
treeec51cb4339782d37889f29383f303f9bdf35faa0 /PyPI/jumpavg/setup.py
parent2f99b522d591a95d6ac4f11db8a34b8162258ecd (diff)
CSIT-1110: Use jumpavg library from pip
+ Move the jumpavg library code to separate directory. - Bump to 0.1.2 has to be done later. Change-Id: I9722ede48f00e99eeb68ca3f91e0bdeee2937973 Signed-off-by: Vratko Polak <vrpolak@cisco.com>
Diffstat (limited to 'PyPI/jumpavg/setup.py')
-rw-r--r--PyPI/jumpavg/setup.py52
1 files changed, 52 insertions, 0 deletions
diff --git a/PyPI/jumpavg/setup.py b/PyPI/jumpavg/setup.py
new file mode 100644
index 0000000000..aa56efd9c9
--- /dev/null
+++ b/PyPI/jumpavg/setup.py
@@ -0,0 +1,52 @@
+"""A setup module for setuptools.
+
+See:
+https://packaging.python.org/en/latest/distributing.html
+"""
+
+from setuptools import setup, find_packages
+from os import path
+from io import open
+
+here = path.abspath(path.dirname(__file__))
+with open(path.join(here, "README.rst"), encoding="utf-8") as f:
+ long_description = f.read()
+
+setup(
+ name="jumpavg",
+ version="0.1.2", # This is currently the only place listing the version.
+ description="Library for finding changes in time series by grouping results.",
+ long_description=long_description,
+ long_description_content_type="text/x-rst",
+ # TODO: Create a separate webpage for jumpavg library.
+ url="https://gerrit.fd.io/r/gitweb?p=csit.git;a=tree;f=PyPI/jumpavg;hb=refs/heads/master",
+ author="Cisco Systems Inc. and/or its affiliates",
+ author_email="csit-dev@lists.fd.io",
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Science/Research",
+ # Pick your license as you wish
+ "License :: OSI Approved :: Apache Software License",
+ "Natural Language :: English",
+ # TODO: Test which Python versions is the code compatible with.
+ "Programming Language :: Python :: 2.7",
+ "Topic :: Scientific/Engineering :: Information Analysis"
+ ],
+ keywords="progression regression anomaly detection",
+ packages=find_packages(exclude=[]),
+ # TODO: python_requires="~=2.7"
+ install_requires=[],
+ # TODO: Include simulator and tests.
+ extras_require={
+ },
+ package_data={
+ },
+ entry_points={
+ "console_scripts": [
+ ],
+ },
+ project_urls={
+ "Bug Reports": "https://jira.fd.io/projects/CSIT/issues",
+ "Source": "https://gerrit.fd.io/r/gitweb?p=csit.git;a=tree;f=PyPI/jumpavg;hb=refs/heads/master",
+ },
+)