aboutsummaryrefslogtreecommitdiffstats
path: root/config/x86/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'config/x86/meson.build')
-rw-r--r--config/x86/meson.build21
1 files changed, 11 insertions, 10 deletions
diff --git a/config/x86/meson.build b/config/x86/meson.build
index 9e5952aa..ae92f86a 100644
--- a/config/x86/meson.build
+++ b/config/x86/meson.build
@@ -1,23 +1,24 @@
# SPDX-License-Identifier: BSD-3-Clause
# Copyright(c) 2017 Intel Corporation
-# for checking defines we need to use the correct compiler flags
-march_opt = ['-march=@0@'.format(machine)]
-
# get binutils version for the workaround of Bug 97
ldver = run_command('ld', '-v').stdout().strip()
if ldver.contains('2.30')
if cc.has_argument('-mno-avx512f')
- march_opt += '-mno-avx512f'
+ machine_args += '-mno-avx512f'
message('Binutils 2.30 detected, disabling AVX512 support as workaround for bug #97')
endif
+ if ldver.contains('2.31') and cc.has_argument('-mno-avx512f')
+ machine_args += '-mno-avx512f'
+ message('Binutils 2.31 detected, disabling AVX512 support as workaround for bug #249')
+ endif
endif
# we require SSE4.2 for DPDK
sse_errormsg = '''SSE4.2 instruction set is required for DPDK.
Please set the machine type to "nehalem" or "corei7" or higher value'''
-if cc.get_define('__SSE4_2__', args: march_opt) == ''
+if cc.get_define('__SSE4_2__', args: machine_args) == ''
error(sse_errormsg)
endif
@@ -37,23 +38,23 @@ else
dpdk_conf.set('RTE_ARCH', 'i686')
endif
-if cc.get_define('__AES__', args: march_opt) != ''
+if cc.get_define('__AES__', args: machine_args) != ''
dpdk_conf.set('RTE_MACHINE_CPUFLAG_AES', 1)
compile_time_cpuflags += ['RTE_CPUFLAG_AES']
endif
-if cc.get_define('__PCLMUL__', args: march_opt) != ''
+if cc.get_define('__PCLMUL__', args: machine_args) != ''
dpdk_conf.set('RTE_MACHINE_CPUFLAG_PCLMULQDQ', 1)
compile_time_cpuflags += ['RTE_CPUFLAG_PCLMULQDQ']
endif
-if cc.get_define('__AVX__', args: march_opt) != ''
+if cc.get_define('__AVX__', args: machine_args) != ''
dpdk_conf.set('RTE_MACHINE_CPUFLAG_AVX', 1)
compile_time_cpuflags += ['RTE_CPUFLAG_AVX']
endif
-if cc.get_define('__AVX2__', args: march_opt) != ''
+if cc.get_define('__AVX2__', args: machine_args) != ''
dpdk_conf.set('RTE_MACHINE_CPUFLAG_AVX2', 1)
compile_time_cpuflags += ['RTE_CPUFLAG_AVX2']
endif
-if cc.get_define('__AVX512F__', args: march_opt) != ''
+if cc.get_define('__AVX512F__', args: machine_args) != ''
dpdk_conf.set('RTE_MACHINE_CPUFLAG_AVX512F', 1)
compile_time_cpuflags += ['RTE_CPUFLAG_AVX512F']
endif