aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/crypto/kasumi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/crypto/kasumi/meson.build')
-rw-r--r--drivers/crypto/kasumi/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/drivers/crypto/kasumi/meson.build b/drivers/crypto/kasumi/meson.build
index a09b0e25..9a8956a0 100644
--- a/drivers/crypto/kasumi/meson.build
+++ b/drivers/crypto/kasumi/meson.build
@@ -1,12 +1,12 @@
# SPDX-License-Identifier: BSD-3-Clause
# Copyright(c) 2018 Intel Corporation
-lib = cc.find_library('libsso_kasumi', required: false)
-if not lib.found()
+lib = cc.find_library('sso_kasumi', required: false)
+if not lib.found() or not cc.has_header('sso_kasumi.h')
build = false
-else
- ext_deps += lib
+ subdir_done()
endif
+ext_deps += lib
sources = files('rte_kasumi_pmd.c', 'rte_kasumi_pmd_ops.c')
deps += ['bus_vdev']