aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/crypto/snow3g/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/crypto/snow3g/meson.build')
-rw-r--r--drivers/crypto/snow3g/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/drivers/crypto/snow3g/meson.build b/drivers/crypto/snow3g/meson.build
new file mode 100644
index 00000000..c566a5f6
--- /dev/null
+++ b/drivers/crypto/snow3g/meson.build
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2019 Intel Corporation
+
+lib = cc.find_library('sso_snow3g', required: false)
+if not lib.found() or not cc.has_header('sso_snow3g.h')
+ build = false
+ subdir_done()
+endif
+
+allow_experimental_apis = true
+ext_deps += lib
+sources = files('rte_snow3g_pmd.c', 'rte_snow3g_pmd_ops.c')
+deps += ['bus_vdev', 'cryptodev']