aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/crypto/zuc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/crypto/zuc/meson.build')
-rw-r--r--drivers/crypto/zuc/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/drivers/crypto/zuc/meson.build b/drivers/crypto/zuc/meson.build
index b8ca7107..2b48072c 100644
--- a/drivers/crypto/zuc/meson.build
+++ b/drivers/crypto/zuc/meson.build
@@ -1,12 +1,12 @@
# SPDX-License-Identifier: BSD-3-Clause
# Copyright(c) 2018 Intel Corporation
-lib = cc.find_library('libsso_zuc', required: false)
-if not lib.found()
+lib = cc.find_library('sso_zuc', required: false)
+if not lib.found() or not cc.has_header('sso_zuc.h')
build = false
-else
- ext_deps += lib
+ subdir_done()
endif
+ext_deps += lib
sources = files('rte_zuc_pmd.c', 'rte_zuc_pmd_ops.c')
deps += ['bus_vdev']