aboutsummaryrefslogtreecommitdiffstats
path: root/test/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/test/meson.build')
-rw-r--r--test/test/meson.build13
1 files changed, 11 insertions, 2 deletions
diff --git a/test/test/meson.build b/test/test/meson.build
index eb3d87a4..a907fd25 100644
--- a/test/test/meson.build
+++ b/test/test/meson.build
@@ -8,6 +8,7 @@ test_sources = files('commands.c',
'test_alarm.c',
'test_atomic.c',
'test_barrier.c',
+ 'test_bpf.c',
'test_byteorder.c',
'test_cmdline.c',
'test_cmdline_cirbuf.c',
@@ -24,7 +25,6 @@ test_sources = files('commands.c',
'test_cryptodev_blockcipher.c',
'test_cycles.c',
'test_debug.c',
- 'test_devargs.c',
'test_distributor.c',
'test_distributor_perf.c',
'test_eal_flags.c',
@@ -98,6 +98,7 @@ test_sources = files('commands.c',
)
test_deps = ['acl',
+ 'bpf',
'cfgfile',
'cmdline',
'cryptodev',
@@ -135,7 +136,7 @@ test_names = [
'cryptodev_sw_kasumi_autotest',
'cryptodev_sw_zuc_autotest',
'cryptodev_sw_armv8_autotest',
- 'cryptodev_sw_mrvl_autotest',
+ 'cryptodev_sw_mvsam_autotest',
'cryptodev_dpaa2_sec_autotest',
'cryptodev_dpaa_sec_autotest',
'cycles_autotest',
@@ -235,6 +236,14 @@ if dpdk_conf.has('RTE_LIBRTE_KNI')
endif
test_dep_objs = []
+compress_test_dep = dependency('zlib', required: false)
+if compress_test_dep.found()
+ test_dep_objs += compress_test_dep
+ test_sources += 'test_compressdev.c'
+ test_deps += 'compressdev'
+ test_names += 'compressdev_autotest'
+endif
+
foreach d:test_deps
def_lib = get_option('default_library')
test_dep_objs += get_variable(def_lib + '_rte_' + d)