aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoryexin <yexin13@huawei.com>2018-07-30 21:34:10 +0800
committeryexin <yexin13@huawei.com>2018-08-01 12:56:08 +0800
commit8944a337eaaf3717b11e0e877c38bfec00d3b6bd (patch)
treea97be1ff54b23e6b0d3be34835bc45648deb4ad1 /CMakeLists.txt
parent51884d17a7e9a5a6f15ac95707303a8479c1013f (diff)
Fix: commit-msg hook conflicts with git-review
Fix bug that the original commit-msg hook will conflict with the one from git-review. Also add an option (RMWS) to CMakelists to enable autoremove trailing whitespace when commit changes. Change-Id: I78a34758d1cf2501814e60b403a25df40de833f9 Signed-off-by: yexin <yexin13@huawei.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt38
1 files changed, 32 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index adb0670..e63100f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,11 @@
CMAKE_MINIMUM_REQUIRED(VERSION 2.8.11)
PROJECT(nStack)
+
+option(RMWS "automatically remove trailing whitespace using git pre-commit hook" OFF)
+option(WITH_SECUREC_LIB "Option description" OFF)
+option(WITH_HAL_LIB "Option description" OFF)
+
SET(CMAKE_C_COMPILER "gcc")
SET(EXECUTABLE_PATH ${CMAKE_CURRENT_LIST_DIR}/release/bin)
SET(LIB_PATH_STATIC ${PROJECT_BINARY_DIR})
@@ -51,14 +56,35 @@ if(commit_template STREQUAL "")
message(STATUS "Setting git commit template...done")
endif()
-if(NOT EXISTS "${CMAKE_SOURCE_DIR}/.git/hooks/commit-msg")
- message(STATUS "Setting git commit hook...")
- execute_process(COMMAND ln -s ${CMAKE_SOURCE_DIR}/scripts/git/commit-msg-hook.py ${CMAKE_SOURCE_DIR}/.git/hooks/commit-msg)
- message(STATUS "Setting git commit hook...done")
+find_program(GIT_REVIEW git-review)
+if(NOT GIT_REVIEW)
+ if(NOT EXISTS "${CMAKE_SOURCE_DIR}/.git/hooks/commit-msg")
+ message(STATUS "git-review not found!")
+ message(STATUS "Setting git commit hook...")
+ execute_process(COMMAND ln -s ${CMAKE_SOURCE_DIR}/scripts/git/commit-msg-hook.py ${CMAKE_SOURCE_DIR}/.git/hooks/commit-msg)
+ message(STATUS "Setting git commit hook...done")
+ endif()
+else()
+ if(NOT EXISTS "${CMAKE_SOURCE_DIR}/.git/hooks/commit-msg")
+ execute_process(COMMAND git-review -s
+ RESULT_VARIABLE git_review_ret)
+ if(${git_review_ret} EQUAL 0)
+ file(APPEND ${CMAKE_SOURCE_DIR}/.git/hooks/commit-msg "${CMAKE_SOURCE_DIR}/scripts/git/commit-msg-hook.py $1")
+ endif()
+ else()
+ file(READ ${CMAKE_SOURCE_DIR}/.git/hooks/commit-msg contents)
+ string(FIND "${contents}" "commit-msg-hook.py" match_ret)
+ if(${match_ret} EQUAL -1)
+ file(APPEND ${CMAKE_SOURCE_DIR}/.git/hooks/commit-msg "${CMAKE_SOURCE_DIR}/scripts/git/commit-msg-hook.py $1")
+ endif()
+ endif()
endif()
-option(WITH_SECUREC_LIB "Option description" OFF)
-option(WITH_HAL_LIB "Option description" OFF)
+if(RMWS)
+ message(STATUS "Setting git pre-commit hook...")
+ execute_process(COMMAND ln -sf ${CMAKE_SOURCE_DIR}/scripts/git/pre-commit ${CMAKE_SOURCE_DIR}/.git/hooks/pre-commit)
+ message(STATUS "Setting git pre-commit hook...done")
+endif()
if(WITH_SECUREC_LIB)
add_definitions(-DSECUREC_LIB)