aboutsummaryrefslogtreecommitdiffstats
path: root/app_example/perf-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app_example/perf-test/CMakeLists.txt')
-rw-r--r--app_example/perf-test/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/app_example/perf-test/CMakeLists.txt b/app_example/perf-test/CMakeLists.txt
new file mode 100644
index 0000000..a22f071
--- /dev/null
+++ b/app_example/perf-test/CMakeLists.txt
@@ -0,0 +1,39 @@
+#########################################################################
+#
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#########################################################################
+
+LINK_DIRECTORIES(${LIB_PATH_SHARED} ${LIB_PATH_STATIC})
+
+ADD_EXECUTABLE(vc_epoll multi_tcp_epoll_app_Cli.c)
+ADD_DEPENDENCIES(vc_epoll nStackAPI)
+TARGET_LINK_LIBRARIES(vc_epoll libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)
+
+ADD_EXECUTABLE(vs_epoll multi_tcp_epoll_app_Ser.c)
+ADD_DEPENDENCIES(vs_epoll nStackAPI)
+TARGET_LINK_LIBRARIES(vs_epoll libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)
+
+ADD_EXECUTABLE(kc_epoll multi_tcp_epoll_app_Cli.c)
+TARGET_LINK_LIBRARIES(kc_epoll pthread)
+
+ADD_EXECUTABLE(ks_epoll multi_tcp_epoll_app_Ser.c)
+TARGET_LINK_LIBRARIES(ks_epoll pthread)
+
+#ADD_EXECUTABLE(vs_no_epoll multi_tcp_no_epoll_Ser.c)
+#ADD_DEPENDENCIES(vs_no_epoll nStackAPI)
+#TARGET_LINK_LIBRARIES(vs_no_epoll libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)
+
+#ADD_EXECUTABLE(ks_no_epoll multi_tcp_no_epoll_Ser.c)
+#TARGET_LINK_LIBRARIES(ks_no_epoll pthread)
+