aboutsummaryrefslogtreecommitdiffstats
path: root/app_example/perf-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app_example/perf-test/CMakeLists.txt')
-rw-r--r--app_example/perf-test/CMakeLists.txt17
1 files changed, 12 insertions, 5 deletions
diff --git a/app_example/perf-test/CMakeLists.txt b/app_example/perf-test/CMakeLists.txt
index a22f071..4abde0f 100644
--- a/app_example/perf-test/CMakeLists.txt
+++ b/app_example/perf-test/CMakeLists.txt
@@ -16,20 +16,27 @@
LINK_DIRECTORIES(${LIB_PATH_SHARED} ${LIB_PATH_STATIC})
-ADD_EXECUTABLE(vc_epoll multi_tcp_epoll_app_Cli.c)
-ADD_DEPENDENCIES(vc_epoll nStackAPI)
-TARGET_LINK_LIBRARIES(vc_epoll libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)
+ADD_EXECUTABLE(vc_common multi_tcp_common_app_Cli.c)
+ADD_DEPENDENCIES(vc_common nStackAPI)
+TARGET_LINK_LIBRARIES(vc_common libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)
ADD_EXECUTABLE(vs_epoll multi_tcp_epoll_app_Ser.c)
ADD_DEPENDENCIES(vs_epoll nStackAPI)
TARGET_LINK_LIBRARIES(vs_epoll libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)
-ADD_EXECUTABLE(kc_epoll multi_tcp_epoll_app_Cli.c)
-TARGET_LINK_LIBRARIES(kc_epoll pthread)
+ADD_EXECUTABLE(vs_select multi_tcp_select_app_Ser.c)
+ADD_DEPENDENCIES(vs_select nStackAPI)
+TARGET_LINK_LIBRARIES(vs_select libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)
+
+ADD_EXECUTABLE(kc_common multi_tcp_common_app_Cli.c)
+TARGET_LINK_LIBRARIES(kc_common pthread)
ADD_EXECUTABLE(ks_epoll multi_tcp_epoll_app_Ser.c)
TARGET_LINK_LIBRARIES(ks_epoll pthread)
+ADD_EXECUTABLE(ks_select multi_tcp_select_app_Ser.c)
+TARGET_LINK_LIBRARIES(ks_select pthread)
+
#ADD_EXECUTABLE(vs_no_epoll multi_tcp_no_epoll_Ser.c)
#ADD_DEPENDENCIES(vs_no_epoll nStackAPI)
#TARGET_LINK_LIBRARIES(vs_no_epoll libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)