summaryrefslogtreecommitdiffstats
path: root/stacks/lwip_stack/src/mem/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'stacks/lwip_stack/src/mem/CMakeLists.txt')
-rw-r--r--stacks/lwip_stack/src/mem/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/stacks/lwip_stack/src/mem/CMakeLists.txt b/stacks/lwip_stack/src/mem/CMakeLists.txt
new file mode 100644
index 0000000..eb4e0b5
--- /dev/null
+++ b/stacks/lwip_stack/src/mem/CMakeLists.txt
@@ -0,0 +1,36 @@
+#########################################################################
+#
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#########################################################################
+
+if(WITH_HAL_LIB)
+else()
+ SET(PAL_H_DIRECTORIES "/usr/include/dpdk/")
+endif()
+
+
+FILE(GLOB_RECURSE MEM *.c)
+ADD_LIBRARY(nsfw_mem STATIC ${MEM})
+ADD_DEPENDENCIES(nsfw_mem GLOG)
+INCLUDE_DIRECTORIES(
+ ${CMAKE_CURRENT_LIST_DIR}/../include
+ ${PAL_H_DIRECTORIES}
+ ${CMAKE_CURRENT_LIST_DIR}/../../../../src/framework/include
+ ${CMAKE_CURRENT_LIST_DIR}/../../../../src/framework/include/common
+ ${CMAKE_CURRENT_LIST_DIR}/../../../../src/include
+ nsfw_shmem/
+ include/
+ ${CMAKE_CURRENT_LIST_DIR}/../include/
+ ${CMAKE_CURRENT_LIST_DIR}/nsfw_nshmem/
+)