summaryrefslogtreecommitdiffstats
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-07-26 17:32:48 +0200
committerMauro Sardara <msardara@cisco.com>2019-07-26 18:08:58 +0200
commit05ca0aa8f612ee48fb66d4dbebe596b7f1e03181 (patch)
tree613d0c2362fdb62df42ce54aae12362ff0d7d2ec /apps/CMakeLists.txt
parent7ceadff88f62665194deb12ca0926f5dcd6d3f48 (diff)
[HICN-253] Mark cmake target for library as static or shared.
Change-Id: I1e8a14f9255f04bddbb87f74a6d6163a02dedb22 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index f59d58f6e..161555c5b 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -34,16 +34,14 @@ else()
if (ANDROID_API)
find_package(OpenSSL REQUIRED)
find_package(ZLIB REQUIRED)
- set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT})
- list(APPEND DEPENDENCIES
- ${LIBTRANSPORT_LIBRARIES}
- )
+ set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT_STATIC})
else ()
set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT_SHARED})
- list(APPEND DEPENDENCIES
- ${LIBTRANSPORT_LIBRARIES}
- )
endif ()
+
+ list(APPEND DEPENDENCIES
+ ${LIBTRANSPORT_LIBRARIES}
+ )
endif()
set(SUFFIX "")