summaryrefslogtreecommitdiffstats
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <manangel@cisco.com>2019-05-14 16:05:53 +0200
committerAngelo Mantellini <manangel@cisco.com>2019-05-16 13:48:23 +0200
commit5c9b2cd16e76b7d731bd31422b4a555dbeff1541 (patch)
tree1ab57c1e0eb10374879803ef9aee36724ad875ef /apps/CMakeLists.txt
parent8a4273ffe83b46bc018da58135427d40012282b8 (diff)
[HICN-195] Generate static libs for android
Change-Id: Ib78e0ba5108713c6fac0e422eb7bb6f7ba10abc7 Signed-off-by: Angelo Mantellini <manangel@cisco.com>
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index 5fed15380..f2a950a6d 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -30,10 +30,19 @@ if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
include_directories(${LIBTRANSPORT_INCLUDE_DIRS})
set(HICN_APPS hicn-apps)
else()
- set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT_SHARED})
- list(APPEND DEPENDENCIES
- ${LIBTRANSPORT_LIBRARIES}
- )
+ if (ANDROID_API)
+ find_package(OpenSSL REQUIRED)
+ find_package(ZLIB REQUIRED)
+ set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT})
+ list(APPEND DEPENDENCIES
+ ${LIBTRANSPORT_LIBRARIES}
+ )
+ else ()
+ set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT_SHARED})
+ list(APPEND DEPENDENCIES
+ ${LIBTRANSPORT_LIBRARIES}
+ )
+ endif ()
endif()
set(SUFFIX "")
@@ -45,6 +54,7 @@ set(HICN_APPS "${HICN_APPS}${SUFFIX}")
list(APPEND LIBRARIES
${LIBTRANSPORT_LIBRARIES}
+ ${OPENSSL_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT}
)