aboutsummaryrefslogtreecommitdiffstats
path: root/apps/http-proxy/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-05-19 15:23:13 +0000
committerGerrit Code Review <gerrit@fd.io>2019-05-19 15:23:13 +0000
commit250e5f768a75a62b001c16932e06055fa64a1a27 (patch)
tree9ac0ac8d50b49faf9d556e914f6d573372eaca70 /apps/http-proxy/CMakeLists.txt
parent0d967df60ea818382dca57316a022b6b967c9254 (diff)
parent7c0e5b9cd797e9bed98fc8d1df411894a4174d87 (diff)
Merge "[HICN-202] Compile apps in release mode if no build mode is specified"
Diffstat (limited to 'apps/http-proxy/CMakeLists.txt')
-rw-r--r--apps/http-proxy/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/apps/http-proxy/CMakeLists.txt b/apps/http-proxy/CMakeLists.txt
index 010a2c2b6..85c044d58 100644
--- a/apps/http-proxy/CMakeLists.txt
+++ b/apps/http-proxy/CMakeLists.txt
@@ -19,6 +19,11 @@ set(CMAKE_MODULE_PATH
"${CMAKE_SOURCE_DIR}/cmake/Modules/"
)
+if (NOT CMAKE_BUILD_TYPE)
+ message(STATUS "No build type selected, default to Release")
+ set(CMAKE_BUILD_TYPE "Release")
+endif ()
+
find_package(Threads REQUIRED)
include_directories(
SYSTEM