summaryrefslogtreecommitdiffstats
path: root/apps/http-proxy/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Augé <jordan.auge+fdio@cisco.com>2020-02-03 10:38:56 +0000
committerGerrit Code Review <gerrit@fd.io>2020-02-03 10:38:56 +0000
commite90a3ec9cbc98d73dfeb2175ee12edfb56af11ee (patch)
tree77b833e5189847e84933ce3269aaa05ffda24138 /apps/http-proxy/CMakeLists.txt
parentb289a24a07d9fe67e8cd9ea0247987e009df6d50 (diff)
parent55f2219ab98b039f256671c5e584a61ab52bfed0 (diff)
Merge "[HICN-489] Add iOS support to hicn stack"
Diffstat (limited to 'apps/http-proxy/CMakeLists.txt')
-rw-r--r--apps/http-proxy/CMakeLists.txt18
1 files changed, 10 insertions, 8 deletions
diff --git a/apps/http-proxy/CMakeLists.txt b/apps/http-proxy/CMakeLists.txt
index cc47e4b6f..94bf895c1 100644
--- a/apps/http-proxy/CMakeLists.txt
+++ b/apps/http-proxy/CMakeLists.txt
@@ -58,11 +58,13 @@ build_library(${LIBHTTP_PROXY}
LINK_FLAGS ${LINK_FLAGS}
)
-build_executable(${HTTP_PROXY}
- SOURCES ${APP_SOURCE_FILES}
- LINK_LIBRARIES ${LIBHTTP_PROXY_STATIC}
- DEPENDS ${LIBHTTP_PROXY_STATIC}
- COMPONENT ${HICN_APPS}
- DEFINITIONS ${COMPILER_DEFINITIONS}
- LINK_FLAGS ${LINK_FLAGS}
-)
+if (NOT DISABLE_EXECUTABLES)
+ build_executable(${HTTP_PROXY}
+ SOURCES ${APP_SOURCE_FILES}
+ LINK_LIBRARIES ${LIBHTTP_PROXY_STATIC}
+ DEPENDS ${LIBHTTP_PROXY_STATIC}
+ COMPONENT ${HICN_APPS}
+ DEFINITIONS ${COMPILER_DEFINITIONS}
+ LINK_FLAGS ${LINK_FLAGS}
+ )
+endif ()