summaryrefslogtreecommitdiffstats
path: root/apps/http-server/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-05-16 15:46:10 +0000
committerGerrit Code Review <gerrit@fd.io>2019-05-16 15:46:10 +0000
commit41ed041613107ae6f1bf9cae5147cfdc71a1ba54 (patch)
treec67e8bcd830e348c0a905fe52d48a248c0031132 /apps/http-server/CMakeLists.txt
parentdb8d063677b42c0ec8191728e55d1d5efef80822 (diff)
parent5c9b2cd16e76b7d731bd31422b4a555dbeff1541 (diff)
Merge "[HICN-195] Generate static libs for android"
Diffstat (limited to 'apps/http-server/CMakeLists.txt')
-rw-r--r--apps/http-server/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/apps/http-server/CMakeLists.txt b/apps/http-server/CMakeLists.txt
index bedb6afc1..65dcc9a98 100644
--- a/apps/http-server/CMakeLists.txt
+++ b/apps/http-server/CMakeLists.txt
@@ -62,6 +62,7 @@ include_directories(
http-client
)
+
set(LIBHTTP_SERVER hicnhttpserver)
build_library(${LIBHTTP_SERVER}
@@ -75,7 +76,7 @@ build_library(${LIBHTTP_SERVER}
build_executable(${HTTP_SERVER}
SOURCES ${APP_SOURCE_FILES}
- LINK_LIBRARIES ${LIBHTTP_SERVER} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
+ LINK_LIBRARIES ${LIBHTTP_SERVER} ${LIBRARIES} ${ZLIB_LIBRARIES} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
DEPENDS ${LIBHTTP_SERVER}
COMPONENT ${HICN_APPS}
DEFINITIONS ${COMPILER_DEFINITIONS}