aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-11-15 08:58:23 +0000
committerAlberto Compagno <acompagn+fdio@cisco.com>2019-11-20 07:58:12 +0000
commit4eb89ea4dcad4c01664b5331745f4e9a38facbd2 (patch)
treef4c6935249f6461a03886ab89532e5563db1f75f /ctrl/CMakeLists.txt
parent40fde5ad542c30e59ac02639e29389085de89de5 (diff)
[HICN-394] Add route commands add, list, del for the hicn-plugin
Signed-off-by: Alberto Compagno <acompagn+fdio@cisco.com> Change-Id: I41641f6d27babaa1c413ecf2fe6eae0e499df97d
Diffstat (limited to 'ctrl/CMakeLists.txt')
-rw-r--r--ctrl/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/ctrl/CMakeLists.txt b/ctrl/CMakeLists.txt
index cdce8bbdb..50357651f 100644
--- a/ctrl/CMakeLists.txt
+++ b/ctrl/CMakeLists.txt
@@ -16,4 +16,7 @@ cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
project(ctrl)
add_subdirectory(libhicnctrl)
-add_subdirectory(facemgr)
+
+if (NOT (BUILD_HICNPLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux"))
+ add_subdirectory(facemgr)
+endif () \ No newline at end of file