aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/facemgr/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <angelo.mantellini@cisco.com>2020-03-31 11:10:00 +0000
committerGerrit Code Review <gerrit@fd.io>2020-03-31 11:10:00 +0000
commit23c3bb7400839b664096ad5e16a2346386109bda (patch)
treed1999acef9f91cd25db9b7c63fd2963cd7ba0e57 /ctrl/facemgr/CMakeLists.txt
parentd46e59824bd3fc67abe7bd725965aa454942d640 (diff)
parent3718e549ee31ac764b327bbf3d6e51dd7e224b46 (diff)
Merge "[HICN-581] update hicn stack to support windows, again"
Diffstat (limited to 'ctrl/facemgr/CMakeLists.txt')
-rw-r--r--ctrl/facemgr/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/ctrl/facemgr/CMakeLists.txt b/ctrl/facemgr/CMakeLists.txt
index a1cd48bbd..4290d9cd6 100644
--- a/ctrl/facemgr/CMakeLists.txt
+++ b/ctrl/facemgr/CMakeLists.txt
@@ -70,7 +70,11 @@ if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
find_package_wrapper(Libhicnctrl REQUIRED)
else()
if (DISABLE_SHARED_LIBRARIES)
- set(HICN_LIBRARIES ${LIBHICN_STATIC} log)
+ if (WIN32)
+ set(HICN_LIBRARIES ${LIBHICN_STATIC})
+ else ()
+ set(HICN_LIBRARIES ${LIBHICN_STATIC} log)
+ endif ()
set(LIBHICNCTRL_LIBRARIES ${LIBHICNCTRL_STATIC})
list(APPEND DEPENDENCIES
${LIBHICN_STATIC}