aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/facemgr/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Augé <jordan.auge+fdio@cisco.com>2019-07-26 23:20:30 +0200
committerMauro Sardara <msardara@cisco.com>2019-07-29 17:13:35 +0200
commit0a1c6b5565e20167d1f1f33a5a8b597f420b18b0 (patch)
tree98c5da8f231fbd3dc2ce6502040e29c8333d9ffc /ctrl/facemgr/src/CMakeLists.txt
parent05ca0aa8f612ee48fb66d4dbebe596b7f1e03181 (diff)
[HICN-252] Add per-application policy framework to hicn-light forwarder
Change-Id: I0531cd7a7de179581295ae34766c81cd9cf3e172 Signed-off-by: Jordan Augé <jordan.auge+fdio@cisco.com> Signed-off-by: Mauro Sardara <msardara@cisco.com> Co-authored-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'ctrl/facemgr/src/CMakeLists.txt')
-rw-r--r--ctrl/facemgr/src/CMakeLists.txt112
1 files changed, 112 insertions, 0 deletions
diff --git a/ctrl/facemgr/src/CMakeLists.txt b/ctrl/facemgr/src/CMakeLists.txt
new file mode 100644
index 000000000..e7dbda5c1
--- /dev/null
+++ b/ctrl/facemgr/src/CMakeLists.txt
@@ -0,0 +1,112 @@
+# Copyright (c) 2017-2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+if(UNIX AND NOT APPLE)
+ set(LINUX TRUE)
+endif()
+
+set(COMPILER_DEFINITIONS
+ "-DWITH_POLICY"
+)
+
+set(HEADER_FILES
+#cache.h
+ common.h
+ error.h
+ event.h
+ face.h
+ face_cache.h
+ face_rules.h
+ interface.h
+ interface_map.h
+ interface_ops_map.h
+ util/hash.h
+ util/ip_address.h
+ util/log.h
+ util/map.h
+ util/policy.h
+ util/set.h
+ util/token.h
+ util/types.h
+
+)
+
+set(SOURCE_FILES
+# cache.c
+ error.c
+ event.c
+ face.c
+ face_cache.c
+ face_rules.c
+ interface.c
+ interface_map.c
+ interface_ops_map.c
+ facemgr.c
+ util/log.c
+ util/policy.c
+)
+
+set(INCLUDE_DIRS
+ ./
+ ../includes/
+ ${CONFIG_INCLUDE_DIR}
+ ${LIBEVENT_INCLUDE_DIR}
+ ${LIBHICNCTRL_INCLUDE_DIRS}
+)
+
+set(LIBRARIES
+ ${CONFIG_LIBRARY}
+ ${LIBEVENT_LIBRARY}
+ ${LIBHICNCTRL_LIBRARIES}
+)
+
+add_subdirectory(interfaces)
+
+if (ANDROID_API)
+ build_library(${FACE_MGR}
+ STATIC
+ SOURCES ${SOURCE_FILES}
+ INSTALL_HEADERS ${TO_INSTALL_HEADER_FILES}
+ DEPENDS ${DEPENDENCIES}
+ COMPONENT ${FACE_MGR}
+ INCLUDE_DIRS ${INCLUDE_DIRS}
+ INSTALL_ROOT_DIR hicn
+ DEFINITIONS ${COMPILER_DEFINITIONS}
+ )
+else ()
+ build_library(${FACE_MGR}
+ STATIC NO_DEV
+ SOURCES ${SOURCE_FILES}
+ INSTALL_HEADERS ${TO_INSTALL_HEADER_FILES}
+ DEPENDS ${DEPENDENCIES}
+ COMPONENT ${FACE_MGR}
+ INCLUDE_DIRS ${INCLUDE_DIRS}
+ INSTALL_ROOT_DIR hicn
+ DEFINITIONS ${COMPILER_DEFINITIONS}
+ )
+endif ()
+
+if(NOT ANDROID_API AND NOT COMPILE_FOR_IOS)
+ list(APPEND DAEMON_SRC
+ main.c
+ )
+
+ build_executable(${FACE_MGR}
+ SOURCES ${DAEMON_SRC}
+ LINK_LIBRARIES ${FACE_MGR}.static ${LIBRARIES}
+ DEPENDS ${FACE_MGR}.static
+ COMPONENT ${FACE_MGR}
+ INCLUDE_DIRS ${INCLUDE_DIRS}
+ DEFINITIONS ${COMPILER_DEFINITIONS}
+ )
+endif ()