aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/libhicnctrl/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-11-19 17:57:20 +0000
committerAlberto Compagno <acompagn+fdio@cisco.com>2019-11-26 10:46:53 +0000
commit3e949f72778dd076fffecd7da2fb83cbb1ccb428 (patch)
treeeb5e437c0bc4be54fc57ae46ae964be7567c43bc /ctrl/libhicnctrl/CMakeLists.txt
parentb3ee2ed8602c909f8d5096e9d8d44aa345093566 (diff)
[HICN-398] Added face create/delete/list and listener list on libctrl for hicn-plugin
Listener list returns the list of interfaces and their ip addresses Signed-off-by: Alberto Compagno <acompagn+fdio@cisco.com> Change-Id: I2582cf29d4f1f60964766d47ad8d6dc64504fd62
Diffstat (limited to 'ctrl/libhicnctrl/CMakeLists.txt')
-rw-r--r--ctrl/libhicnctrl/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/ctrl/libhicnctrl/CMakeLists.txt b/ctrl/libhicnctrl/CMakeLists.txt
index 43d120473..59620088e 100644
--- a/ctrl/libhicnctrl/CMakeLists.txt
+++ b/ctrl/libhicnctrl/CMakeLists.txt
@@ -58,6 +58,7 @@ else()
${HICNPLUGIN_INCLUDE_DIRS})
set(HICN_LIBRARIES ${HICNPLUGIN_LIBRARIES})
+ set(LINK_FLAGS "-Wl,-unresolved-symbols=ignore-in-shared-libs")
list(APPEND DEPENDENCIES
hicn_plugin