aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/sysrepo-plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorAberto Compagno <acompagn+fdio@cisco.com>2020-02-05 16:53:44 +0000
committerAberto Compagno <acompagn+fdio@cisco.com>2020-02-05 16:53:44 +0000
commit39de2261effa781dc3d0f1edde1148afc9456d27 (patch)
treee19cce890180425992bc80b3ce74d2a822a96c0b /ctrl/sysrepo-plugins/CMakeLists.txt
parent37fd13f62206f9539b3102a2ceba2f96e1be2538 (diff)
[HICN-504] Added hicn yang model to the hicn-sysrepo-plugin package
Signed-off-by: Aberto Compagno <acompagn+fdio@cisco.com> Change-Id: I1679360a23fd7b790582c754d25fd6b4709fbfde
Diffstat (limited to 'ctrl/sysrepo-plugins/CMakeLists.txt')
-rw-r--r--ctrl/sysrepo-plugins/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/ctrl/sysrepo-plugins/CMakeLists.txt b/ctrl/sysrepo-plugins/CMakeLists.txt
index 8c1278c1c..f1e1553dc 100644
--- a/ctrl/sysrepo-plugins/CMakeLists.txt
+++ b/ctrl/sysrepo-plugins/CMakeLists.txt
@@ -53,6 +53,15 @@ endif()
add_subdirectory(hicn-plugin)
+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/yang/hicn/hicn.yang
+ ${CMAKE_CURRENT_SOURCE_DIR}/yang/ietf/iana-if-type@2014-05-08.yang
+ ${CMAKE_CURRENT_SOURCE_DIR}/yang/ietf/ietf-interfaces.yang
+ ${CMAKE_CURRENT_SOURCE_DIR}/yang/ietf/ietf-ip@2014-06-16.yang
+ ${CMAKE_CURRENT_SOURCE_DIR}/yang/ietf/ietf-yang-types@2013-07-15.yang
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/modules_yang/
+ COMPONENT hicn-sysrepo-plugin)
+
+
include(Packaging)
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
include(Packager)