aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/sysrepo-plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2020-02-06 08:22:09 +0000
committerGerrit Code Review <gerrit@fd.io>2020-02-06 08:22:09 +0000
commit8dbcb75d20ca33bf495bcd68e8ca0dd1fe228703 (patch)
treeeb40b577179ec5fb30a756e1ba0f77ced899c7c4 /ctrl/sysrepo-plugins/CMakeLists.txt
parent2f6e378577c7976aeb4d0b054a15aa3964a2c9de (diff)
parent39de2261effa781dc3d0f1edde1148afc9456d27 (diff)
Merge "[HICN-504] Added hicn yang model to the hicn-sysrepo-plugin package"
Diffstat (limited to 'ctrl/sysrepo-plugins/CMakeLists.txt')
-rw-r--r--ctrl/sysrepo-plugins/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/ctrl/sysrepo-plugins/CMakeLists.txt b/ctrl/sysrepo-plugins/CMakeLists.txt
index 8c1278c1c..f1e1553dc 100644
--- a/ctrl/sysrepo-plugins/CMakeLists.txt
+++ b/ctrl/sysrepo-plugins/CMakeLists.txt
@@ -53,6 +53,15 @@ endif()
add_subdirectory(hicn-plugin)
+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/yang/hicn/hicn.yang
+ ${CMAKE_CURRENT_SOURCE_DIR}/yang/ietf/iana-if-type@2014-05-08.yang
+ ${CMAKE_CURRENT_SOURCE_DIR}/yang/ietf/ietf-interfaces.yang
+ ${CMAKE_CURRENT_SOURCE_DIR}/yang/ietf/ietf-ip@2014-06-16.yang
+ ${CMAKE_CURRENT_SOURCE_DIR}/yang/ietf/ietf-yang-types@2013-07-15.yang
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/modules_yang/
+ COMPONENT hicn-sysrepo-plugin)
+
+
include(Packaging)
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
include(Packager)