aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/sysrepo-plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-12-12 11:11:52 +0100
committerMauro Sardara <msardara@cisco.com>2019-12-12 13:20:53 +0100
commit017f79bce9a131cb0369885321229db034488e7e (patch)
tree578bd07556508808b90ecc18917f1963780deda1 /ctrl/sysrepo-plugins/CMakeLists.txt
parentabc8c3c68b45567b4bbc2c851a944b778e79331c (diff)
[HICN-449] Correct dependencies of DEB/RPM package for sysrepo.
Change-Id: Ie3f7f700617d99e7e56431afbb1b877e6cb366f9 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'ctrl/sysrepo-plugins/CMakeLists.txt')
-rw-r--r--ctrl/sysrepo-plugins/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/ctrl/sysrepo-plugins/CMakeLists.txt b/ctrl/sysrepo-plugins/CMakeLists.txt
index 1a9bca18c..8c1278c1c 100644
--- a/ctrl/sysrepo-plugins/CMakeLists.txt
+++ b/ctrl/sysrepo-plugins/CMakeLists.txt
@@ -41,14 +41,12 @@ if (NOT SRPD_PLUGINS_PATH)
message(FATAL_ERROR "Cannot get sysrepo plugins directory due to missing pkg-config, set SRPD_PLUGINS_PATH manually.")
endif()
+find_package(Vpp REQUIRED)
+
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
- find_package(Vpp REQUIRED)
find_package(HicnPlugin REQUIRED)
- find_package(Libhicn REQUIRED)
else()
list(APPEND DEPENDENCIES
- ${LIBHICN_SHARED}
- ${LIBHICN_STATIC}
hicn_plugin
)
endif()