summaryrefslogtreecommitdiffstats
path: root/ctrl/sysrepo-plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-12-12 12:41:15 +0000
committerGerrit Code Review <gerrit@fd.io>2019-12-12 12:41:15 +0000
commitd4f976ac3a063f7ebc8e55584c98502ce9a3dc3f (patch)
tree781223ba6493b8565f72262cb6d8a32ba6aa210b /ctrl/sysrepo-plugins/CMakeLists.txt
parent44ecc43d1680bfb5d338a649f235b15d45b00695 (diff)
parent017f79bce9a131cb0369885321229db034488e7e (diff)
Merge "[HICN-449] Correct dependencies of DEB/RPM package for sysrepo."
Diffstat (limited to 'ctrl/sysrepo-plugins/CMakeLists.txt')
-rw-r--r--ctrl/sysrepo-plugins/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/ctrl/sysrepo-plugins/CMakeLists.txt b/ctrl/sysrepo-plugins/CMakeLists.txt
index 1a9bca18c..8c1278c1c 100644
--- a/ctrl/sysrepo-plugins/CMakeLists.txt
+++ b/ctrl/sysrepo-plugins/CMakeLists.txt
@@ -41,14 +41,12 @@ if (NOT SRPD_PLUGINS_PATH)
message(FATAL_ERROR "Cannot get sysrepo plugins directory due to missing pkg-config, set SRPD_PLUGINS_PATH manually.")
endif()
+find_package(Vpp REQUIRED)
+
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
- find_package(Vpp REQUIRED)
find_package(HicnPlugin REQUIRED)
- find_package(Libhicn REQUIRED)
else()
list(APPEND DEPENDENCIES
- ${LIBHICN_SHARED}
- ${LIBHICN_STATIC}
hicn_plugin
)
endif()