aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/sysrepo-plugins/hicn-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authormashemat <mhemmatp@cisco.com>2019-11-13 11:48:09 +0100
committerMasoud Hemmatpour <mhemmatp@cisco.com>2019-11-14 09:10:05 +0000
commitcd09afb42f41f8bb6cc9db3d13b3f353fa69d94f (patch)
treefe81d6c08c4e5364fa7c2533ce9f13a2e518fd33 /ctrl/sysrepo-plugins/hicn-plugin/CMakeLists.txt
parent4f57ca72e8131e5cfb023b26417b924e774d5e73 (diff)
[HICN-375] Move cmake in ctrl/sysrepo-plugins to the main cmke in root
Signed-off-by: mashemat <mhemmatp@cisco.com> Change-Id: I6c2f65e61a2f13db8261a32482336b21f07d5e45
Diffstat (limited to 'ctrl/sysrepo-plugins/hicn-plugin/CMakeLists.txt')
-rw-r--r--ctrl/sysrepo-plugins/hicn-plugin/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/ctrl/sysrepo-plugins/hicn-plugin/CMakeLists.txt b/ctrl/sysrepo-plugins/hicn-plugin/CMakeLists.txt
index 4c3ef6d1a..37590ee4c 100644
--- a/ctrl/sysrepo-plugins/hicn-plugin/CMakeLists.txt
+++ b/ctrl/sysrepo-plugins/hicn-plugin/CMakeLists.txt
@@ -22,7 +22,9 @@ cmake_minimum_required(VERSION 2.8)
project(sysrepo-vpp-plugins)
# Cmake find modules
-list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/../cmake")
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/../cmake/Modules"
+"${CMAKE_CURRENT_LIST_DIR}/../../../cmake/Modules"
+)
find_package(VPP)
find_package(PkgConfig)
@@ -54,7 +56,7 @@ set(PLUGINS_SOURCES
# build the source code into shared library
add_library(hicn SHARED ${PLUGINS_SOURCES})
target_include_directories(hicn PUBLIC ${VPP_INCLUDE_DIRS} ${HICNPLUGIN_INCLUDE_DIRS})
-target_link_libraries(hicn ${SYSREPO_LIBRARIES} ${VPP_LIBRARIES} ${HICNPLUGIN_LIBRARIES})
+target_link_libraries(hicn ${SYSREPO_LIBRARIES} ${VPP_LIBRARIES})
#set_target_properties(hicn
# PROPERTIES