aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2020-09-07 19:58:45 +0200
committerMauro Sardara <msardara@cisco.com>2020-09-09 09:37:22 +0000
commit91529a777fd3f56aeadef19dc25e196ba2e1cc51 (patch)
tree215433c0715cbaf74c25f4c6c2893907bda146bc /hicn-light/CMakeLists.txt
parentaba0a8ce4aeae0392b71658e9afaedc0d857a1a7 (diff)
[HICN-636] Add gtest framework and first tests for loop.
Signed-off-by: Mauro Sardara <msardara@cisco.com> Change-Id: I133c8adda125c430aa9c4a35fb63bf1d8585afe9 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'hicn-light/CMakeLists.txt')
-rw-r--r--hicn-light/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/hicn-light/CMakeLists.txt b/hicn-light/CMakeLists.txt
index dd7d7fcc2..5d0d59b43 100644
--- a/hicn-light/CMakeLists.txt
+++ b/hicn-light/CMakeLists.txt
@@ -84,9 +84,9 @@ find_package(Threads REQUIRED)
set(LIBHICN_LIGHT hicn-light)
set(LIBHICN_LIGHT_STATIC ${LIBHICN_LIGHT}.static)
+set(LIBHICN_LIGHT_SHARED ${LIBHICN_LIGHT}.shared)
set(HICN_LIGHT_LINK_LIBRARIES
- ${LIBHICN_LIGHT_STATIC}
${HICN_LIBRARIES}
${LIBEVENT_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT}
@@ -114,6 +114,16 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "AppleClang")
message(STATUS "Set \"-undefined dynamic_lookup\" for shared libraries")
endif()
+if (BUILD_TESTS)
+ include (GTestImport)
+
+ if(${CMAKE_VERSION} VERSION_GREATER "3.10.0")
+ include (GoogleTest)
+ else()
+ include (CTest)
+ endif()
+endif()
+
add_subdirectory(src/hicn)
# Install service file in linux systems