aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <manangel@cisco.com>2019-01-31 18:20:48 +0100
committerAngelo Mantellini <manangel@cisco.com>2019-02-01 15:23:03 +0100
commitf5a0b8a5e24cede05e15ab696f0e15257a503525 (patch)
tree8cab87196baf7ea5468cebc4002da45175d91ae8 /hicn-light/CMakeLists.txt
parentbf29f9a52ffa3a1f32f700e4fd36ea53885d83aa (diff)
[HICN24] Windows compatibility for hicn-light
Change-Id: I8e19e52c9b4ec0fcbd7344c28765f5da1937569c Signed-off-by: Angelo Mantellini <manangel@cisco.com>
Diffstat (limited to 'hicn-light/CMakeLists.txt')
-rw-r--r--hicn-light/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/hicn-light/CMakeLists.txt b/hicn-light/CMakeLists.txt
index 1a5a7f9e2..c8579c70b 100644
--- a/hicn-light/CMakeLists.txt
+++ b/hicn-light/CMakeLists.txt
@@ -19,7 +19,9 @@ set(CMAKE_C_STANDARD_REQUIRED ON)
include( CTest )
include( detectCacheSize )
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+if(NOT WIN32)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+endif()
if(ANDROID_API)
message("############ Detected cross compile for $ENV{CMAKE_SYSTEM_NAME}")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${ANDROID_C_FLAGS}")
@@ -28,11 +30,13 @@ if(ANDROID_API)
set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -DLIBRTA_DISABLE_VALIDATION -DPARCLibrary_DISABLE_VALIDATION")
include(IosMacros)
+include(WindowsMacros)
find_package_wrapper(Libparc REQUIRED)
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
find_package_wrapper(Libhicn REQUIRED)
+ find_package_wrapper(Libparc REQUIRED)
set(LIBHICN_LIGHT hicn-light)
set(HICN_LIGHT_CONTROL hicnLightControl)
set(HICN_LIGHT_DAEMON hicnLightDaemon)
@@ -53,12 +57,14 @@ set(HICN_LIGHT_LINK_LIBRARIES
${HICN_LIBRARIES}
${LIBPARC_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT}
+ ${WINDOWS_LIBRARIES}
)
# Include dirs -- Order does matter!
list(APPEND HICN_LIGHT_INCLUDE_DIRS
${HICN_INCLUDE_DIRS}
${LIBPARC_INCLUDE_DIRS}
+ ${PTHREAD_INCLUDE_DIRS}
)
if (UNIX)