aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-03-23 11:25:50 +0100
committerMauro Sardara <msardara@cisco.com>2019-03-23 10:29:09 +0000
commita2bdc00ea25f89185c1095a48a8f51cb2c1a20e6 (patch)
tree41756c289ed9ffed68998a12f2562a955b134296 /hicn-light/src/CMakeLists.txt
parente6d4612011483b267dc9f47c5d2b2444dd88f402 (diff)
[HICN-137] Install header file with API with hicn-light.
Change-Id: Idf5405b0086e74ad46dd407edb2598f363886ba3 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'hicn-light/src/CMakeLists.txt')
-rw-r--r--hicn-light/src/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/hicn-light/src/CMakeLists.txt b/hicn-light/src/CMakeLists.txt
index 68ef851f1..c7a4b5efd 100644
--- a/hicn-light/src/CMakeLists.txt
+++ b/hicn-light/src/CMakeLists.txt
@@ -36,18 +36,14 @@ list(INSERT HICN_LIGHT_INCLUDE_DIRS 0
${CMAKE_CURRENT_SOURCE_DIR}/..
)
-if (INSTALL_HEADER)
- set(TO_INSTALL_HEADERS ${HEADER_FILES})
-endif()
-
build_library(${LIBHICN_LIGHT}
STATIC
SOURCES ${SOURCE_FILES}
- INSTALL_HEADERS ${TO_INSTALL_HEADERS}
+ INSTALL_HEADERS ${TO_INSTALL_HEADER_FILES}
LINK_LIBRARIES ${LIBRARIES}
DEPENDS ${DEPENDENCIES}
COMPONENT ${LIBHICN_LIGHT}
INCLUDE_DIRS ${HICN_LIGHT_INCLUDE_DIRS}
- INSTALL_ROOT_DIR hicn/hicn-light
+ INSTALL_ROOT_DIR hicn/light
DEFINITIONS ${COMPILER_DEFINITIONS}
)