aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLuca Muscariello <lumuscar+fdio@cisco.com>2019-03-23 14:13:53 +0100
committerAngelo Mantellini <manangel@cisco.com>2019-03-24 14:11:17 +0100
commiteb323e056e747d71867cf965434811c1de925de2 (patch)
tree23a6096823d795efe448559cf0409a18ab47932d /hicn-light/src/CMakeLists.txt
parent43562f9f02d35e5d540ab4028a0326c0c7cd4898 (diff)
[HICN-141] Definition of a C API for hicn-light
Change-Id: Id861f0abe58b1e3c9ba8cc76701da0f9c6801748 Signed-off-by: Luca Muscariello <lumuscar+fdio@cisco.com> Signed-off-by: Angelo Mantellini <manangel@cisco.com>
Diffstat (limited to 'hicn-light/src/CMakeLists.txt')
-rw-r--r--hicn-light/src/CMakeLists.txt49
1 files changed, 0 insertions, 49 deletions
diff --git a/hicn-light/src/CMakeLists.txt b/hicn-light/src/CMakeLists.txt
deleted file mode 100644
index c7a4b5efd..000000000
--- a/hicn-light/src/CMakeLists.txt
+++ /dev/null
@@ -1,49 +0,0 @@
-# Define a few configuration variables that we want accessible in the software
-
-include(BuildMacros)
-configure_file(config.h.in config.h @ONLY)
-
-if(NOT ANDROID_API AND NOT COMPILE_FOR_IOS)
- add_subdirectory(command_line)
-endif ()
-
-add_subdirectory(config)
-add_subdirectory(content_store)
-add_subdirectory(core)
-add_subdirectory(io)
-add_subdirectory(messenger)
-add_subdirectory(platforms)
-add_subdirectory(processor)
-add_subdirectory(socket)
-add_subdirectory(strategies)
-add_subdirectory(utils)
-
-list(APPEND HEADER_FILES
- ${CMAKE_CURRENT_BINARY_DIR}/config.h
-)
-
-if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux" AND ENABLE_PUNTING)
- list(APPEND COMPILER_DEFINITIONS
- "-DPUNTING"
- )
-endif()
-
-list(APPEND COMPILER_DEFINITIONS
- "-DWITH_MAPME -DWITH_MAPME_FIXES"
-)
-
-list(INSERT HICN_LIGHT_INCLUDE_DIRS 0
- ${CMAKE_CURRENT_SOURCE_DIR}/..
-)
-
-build_library(${LIBHICN_LIGHT}
- STATIC
- SOURCES ${SOURCE_FILES}
- INSTALL_HEADERS ${TO_INSTALL_HEADER_FILES}
- LINK_LIBRARIES ${LIBRARIES}
- DEPENDS ${DEPENDENCIES}
- COMPONENT ${LIBHICN_LIGHT}
- INCLUDE_DIRS ${HICN_LIGHT_INCLUDE_DIRS}
- INSTALL_ROOT_DIR hicn/light
- DEFINITIONS ${COMPILER_DEFINITIONS}
-)