aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/src/hicn/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-07-26 17:32:48 +0200
committerMauro Sardara <msardara@cisco.com>2019-07-26 18:08:58 +0200
commit05ca0aa8f612ee48fb66d4dbebe596b7f1e03181 (patch)
tree613d0c2362fdb62df42ce54aae12362ff0d7d2ec /hicn-light/src/hicn/CMakeLists.txt
parent7ceadff88f62665194deb12ca0926f5dcd6d3f48 (diff)
[HICN-253] Mark cmake target for library as static or shared.
Change-Id: I1e8a14f9255f04bddbb87f74a6d6163a02dedb22 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'hicn-light/src/hicn/CMakeLists.txt')
-rw-r--r--hicn-light/src/hicn/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/hicn-light/src/hicn/CMakeLists.txt b/hicn-light/src/hicn/CMakeLists.txt
index bcef7c9dd..a9861c32d 100644
--- a/hicn-light/src/hicn/CMakeLists.txt
+++ b/hicn-light/src/hicn/CMakeLists.txt
@@ -10,7 +10,6 @@ endif ()
add_subdirectory(config)
add_subdirectory(content_store)
add_subdirectory(core)
-add_subdirectory(api)
add_subdirectory(io)
add_subdirectory(messenger)
add_subdirectory(platforms)
@@ -49,7 +48,7 @@ if (ANDROID_API)
INSTALL_HEADERS ${TO_INSTALL_HEADER_FILES}
LINK_LIBRARIES ${LIBRARIES}
DEPENDS ${DEPENDENCIES}
- COMPONENT ${LIBHICN_LIGHT}
+ COMPONENT ${HICN_LIGHT}
INCLUDE_DIRS ${HICN_LIGHT_INCLUDE_DIRS}
INSTALL_ROOT_DIR hicn
DEFINITIONS ${COMPILER_DEFINITIONS}
@@ -61,7 +60,7 @@ else ()
INSTALL_HEADERS ${TO_INSTALL_HEADER_FILES}
LINK_LIBRARIES ${LIBRARIES}
DEPENDS ${DEPENDENCIES}
- COMPONENT ${LIBHICN_LIGHT}
+ COMPONENT ${HICN_LIGHT}
INCLUDE_DIRS ${HICN_LIGHT_INCLUDE_DIRS}
INSTALL_ROOT_DIR hicn
DEFINITIONS ${COMPILER_DEFINITIONS}