aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/src/hicn/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-03-25 10:39:24 +0100
committerMauro Sardara <msardara@cisco.com>2019-03-25 12:20:33 +0100
commit558581790763815071e9c77e06047e689faf752f (patch)
treebbd8bd357e7ed588ea863116e2873c53260d697d /hicn-light/src/hicn/CMakeLists.txt
parent777974a5b295cbe7ff762358ac3e9dac4c502aaf (diff)
[HICN-141] Install headers in hicn-light component.
Change-Id: I3c7aef4f6ecd147156ecab6aaa6cb2845768645f Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'hicn-light/src/hicn/CMakeLists.txt')
-rw-r--r--hicn-light/src/hicn/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/hicn-light/src/hicn/CMakeLists.txt b/hicn-light/src/hicn/CMakeLists.txt
index 2130c1c39..1b63f7535 100644
--- a/hicn-light/src/hicn/CMakeLists.txt
+++ b/hicn-light/src/hicn/CMakeLists.txt
@@ -38,14 +38,14 @@ list(INSERT HICN_LIGHT_INCLUDE_DIRS 0
)
build_library(${LIBHICN_LIGHT}
- STATIC
+ STATIC NO_DEV
SOURCES ${SOURCE_FILES}
INSTALL_HEADERS ${TO_INSTALL_HEADER_FILES}
LINK_LIBRARIES ${LIBRARIES}
DEPENDS ${DEPENDENCIES}
COMPONENT ${LIBHICN_LIGHT}
INCLUDE_DIRS ${HICN_LIGHT_INCLUDE_DIRS}
- INSTALL_ROOT_DIR hicn/light
+ INSTALL_ROOT_DIR hicn
DEFINITIONS ${COMPILER_DEFINITIONS}
)