summaryrefslogtreecommitdiffstats
path: root/hicn-light/src/hicn/api/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-07-26 17:32:48 +0200
committerMauro Sardara <msardara@cisco.com>2019-07-26 18:08:58 +0200
commit05ca0aa8f612ee48fb66d4dbebe596b7f1e03181 (patch)
tree613d0c2362fdb62df42ce54aae12362ff0d7d2ec /hicn-light/src/hicn/api/CMakeLists.txt
parent7ceadff88f62665194deb12ca0926f5dcd6d3f48 (diff)
[HICN-253] Mark cmake target for library as static or shared.
Change-Id: I1e8a14f9255f04bddbb87f74a6d6163a02dedb22 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'hicn-light/src/hicn/api/CMakeLists.txt')
-rw-r--r--hicn-light/src/hicn/api/CMakeLists.txt51
1 files changed, 0 insertions, 51 deletions
diff --git a/hicn-light/src/hicn/api/CMakeLists.txt b/hicn-light/src/hicn/api/CMakeLists.txt
deleted file mode 100644
index a2be46948..000000000
--- a/hicn-light/src/hicn/api/CMakeLists.txt
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright (c) 2017-2019 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
-
-set(HEADER_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/api.h
- ${CMAKE_CURRENT_SOURCE_DIR}/commands.h
- ${CMAKE_CURRENT_SOURCE_DIR}/face.h
- ${CMAKE_CURRENT_SOURCE_DIR}/ip_address.h
- ${CMAKE_CURRENT_SOURCE_DIR}/token.h
- ${CMAKE_CURRENT_SOURCE_DIR}/types.h
-)
-
-set(SOURCE_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/api.c
-)
-
-set(TO_INSTALL_HEADER_FILES
- ${TO_INSTALL_HEADER_FILES}
- ${HEADER_FILES}
- PARENT_SCOPE
-)
-
-if (ANDROID_API)
- build_library(hicn-light-ctrl
- STATIC
- SOURCES ${SOURCE_FILES}
- COMPONENT ${LIBHICN_LIGHT}
- LINK_LIBRARIES ${HICN_LIGHT_LINK_LIBRARIES}
- DEPENDS ${LIBHICN_LIGHT}
- )
-else ()
- build_library(hicn-light-ctrl
- STATIC SHARED
- SOURCES ${SOURCE_FILES}
- COMPONENT ${LIBHICN_LIGHT}
- LINK_LIBRARIES ${HICN_LIGHT_LINK_LIBRARIES}
- DEPENDS ${LIBHICN_LIGHT}
- )
-endif () \ No newline at end of file