aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/src/hicn/content_store/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Augé <jordan.auge+fdio@cisco.com>2020-04-27 09:42:17 +0000
committerGerrit Code Review <gerrit@fd.io>2020-04-27 09:42:17 +0000
commite94a00b51ce795a8629c33edefd3fcd4b4af05ef (patch)
treeda6b4eb58ec6cb6042b21b05fa194fad9b5d6b8e /hicn-light/src/hicn/content_store/CMakeLists.txt
parent0ea5735b98f38beacf92dfdca74b7a6d5b3f7182 (diff)
parent15ad172a847fa667c57a4594ef4158405db9a984 (diff)
Merge "[HICN-554] hicn-light refactoring" into hicn-light-ng
Diffstat (limited to 'hicn-light/src/hicn/content_store/CMakeLists.txt')
-rw-r--r--hicn-light/src/hicn/content_store/CMakeLists.txt14
1 files changed, 3 insertions, 11 deletions
diff --git a/hicn-light/src/hicn/content_store/CMakeLists.txt b/hicn-light/src/hicn/content_store/CMakeLists.txt
index 85643cf5e..45cfe2267 100644
--- a/hicn-light/src/hicn/content_store/CMakeLists.txt
+++ b/hicn-light/src/hicn/content_store/CMakeLists.txt
@@ -14,20 +14,12 @@
cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
list(APPEND HEADER_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/contentStoreEntry.h
- ${CMAKE_CURRENT_SOURCE_DIR}/contentStoreInterface.h
- ${CMAKE_CURRENT_SOURCE_DIR}/contentStoreLRU.h
- ${CMAKE_CURRENT_SOURCE_DIR}/listTimeOrdered.h
- ${CMAKE_CURRENT_SOURCE_DIR}/listLRU.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/lru.h
)
list(APPEND SOURCE_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/contentStoreInterface.c
- ${CMAKE_CURRENT_SOURCE_DIR}/contentStoreLRU.c
- ${CMAKE_CURRENT_SOURCE_DIR}/listLRU.c
- ${CMAKE_CURRENT_SOURCE_DIR}/listTimeOrdered.c
- ${CMAKE_CURRENT_SOURCE_DIR}/contentStoreEntry.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/lru.c
)
set(SOURCE_FILES ${SOURCE_FILES} PARENT_SCOPE)
-set(HEADER_FILES ${HEADER_FILES} PARENT_SCOPE) \ No newline at end of file
+set(HEADER_FILES ${HEADER_FILES} PARENT_SCOPE)