aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-plugin/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2023-01-30 21:14:39 +0000
committerMauro Sardara <msardara@cisco.com>2023-02-13 08:56:58 +0000
commit7cfd91a6c6316fe15186c8cd3acc1c4526db7e25 (patch)
tree5c05efb8d9e1e9eebcc9d78b209b839860242ba1 /hicn-plugin/src/CMakeLists.txt
parent1c5c85e5f897553d70a07e1ae3104b876c760133 (diff)
feat(hicn-plugin): handle case of no exact match for mapme IU
Ticket: HICN-844 Change-Id: I1f046e6327e4cf507b7fa7a5adae53e63ab491bf Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'hicn-plugin/src/CMakeLists.txt')
-rw-r--r--hicn-plugin/src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/hicn-plugin/src/CMakeLists.txt b/hicn-plugin/src/CMakeLists.txt
index 9524b011a..b7fa828f3 100644
--- a/hicn-plugin/src/CMakeLists.txt
+++ b/hicn-plugin/src/CMakeLists.txt
@@ -179,6 +179,7 @@ set(COMPILER_OPTIONS
##############################################################
set(COMPILE_DEFINITIONS
"-DHICN_VPP_PLUGIN=1"
+ "-DHICN_MAPME_ALLOW_NONEXISTING_FIB_ENTRY"
)
if (${CMAKE_BUILD_TYPE} MATCHES "Debug")