aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <manangel@cisco.com>2019-02-08 15:11:57 +0100
committerAngelo Mantellini <manangel@cisco.com>2019-02-12 10:53:54 +0100
commitf126f86da5acf088f24e97ecb32f9ba5a1789aa4 (patch)
treeb81704d6048117cbe15a398a3f6f5d974d143d14 /lib/CMakeLists.txt
parent3447d02974947d10440e4aa5627318c29be95c01 (diff)
[HICN-44] Remove warnings libhicn (lib) on windows
Change-Id: I637e9c1e05de8a9e6743ea729b62d3eedd6ca54b Signed-off-by: Angelo Mantellini <manangel@cisco.com>
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 796de8df8..a18777cd1 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -39,7 +39,11 @@ if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release")
endif()
-set(CMAKE_C_FLAGS -Wall)
+if (NOT WIN32)
+ set(CMAKE_C_FLAGS -Wall)
+else ()
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /wd4996")
+endif ()
if (ANDROID_API)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${ANDROID_C_FLAGS} -std=c99")