summaryrefslogtreecommitdiffstats
path: root/libtransport/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-05-13 14:44:51 +0000
committerGerrit Code Review <gerrit@fd.io>2019-05-13 14:44:51 +0000
commit8a4273ffe83b46bc018da58135427d40012282b8 (patch)
tree6b56b41dde64a8841ba7a741e8fa4c4b2fe56f2e /libtransport/CMakeLists.txt
parentbab3d0943eeaf8a042971cb3b80ce839c0767c51 (diff)
parent0a0e51426506985ae1e7cf8c581d109fdad7a725 (diff)
Merge "[HICN-194] support for android environment"
Diffstat (limited to 'libtransport/CMakeLists.txt')
-rw-r--r--libtransport/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
index 5cd33cfdc..757521574 100644
--- a/libtransport/CMakeLists.txt
+++ b/libtransport/CMakeLists.txt
@@ -107,6 +107,10 @@ if (${COMPILE_TESTS})
)
endif()
+if(ANDROID_API)
+find_package(OpenSSL REQUIRED)
+endif ()
+
list(APPEND LIBRARIES
${LIBPARC_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT}