summaryrefslogtreecommitdiffstats
path: root/libtransport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-12-03 16:00:27 +0000
committerAlberto Compagno <acompagn+fdio@cisco.com>2019-12-04 09:08:34 +0000
commit36d699cc16a609cb7cd87945b5a618448dca5889 (patch)
tree9e9d6acdfcf53a33ffc81c6c630ab86b18fd728e /libtransport/CMakeLists.txt
parentac2224ae8845f414c1a7fa85aab4e7287fb1df84 (diff)
[HICN-428] Creating libctrl deb and rpm packages specific for hicn-plugin
Signed-off-by: Alberto Compagno <acompagn+fdio@cisco.com> Change-Id: I2460276eb400777105d3351dffdaf8452f01c51f
Diffstat (limited to 'libtransport/CMakeLists.txt')
-rw-r--r--libtransport/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
index a76e91208..d58df5c07 100644
--- a/libtransport/CMakeLists.txt
+++ b/libtransport/CMakeLists.txt
@@ -70,9 +70,11 @@ find_package_wrapper(Libparc REQUIRED)
find_package_wrapper(Asio REQUIRED)
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
+ set(LIBTRANSPORT hicntransport)
if (__vpp__)
find_package_wrapper(HicnPlugin REQUIRED)
find_package(Libmemif REQUIRED)
+ set(LIBTRANSPORT ${LIBTRANSPORT}-memif)
list(APPEND LIBRARIES
${LIBMEMIF_LIBRARIES}
@@ -81,7 +83,6 @@ if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
find_package_wrapper(Libhicn REQUIRED)
- set(LIBTRANSPORT hicntransport)
set(LIBTRANSPORT_SHARED ${LIBTRANSPORT}.shared)
set(LIBTRANSPORT_STATIC ${LIBTRANSPORT}.static)
else()