summaryrefslogtreecommitdiffstats
path: root/libtransport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2020-01-27 16:04:33 +0100
committerAlberto Compagno <acompagn+fdio@cisco.com>2020-01-27 16:56:28 +0100
commitb0768b35fb515b7c0a15c3c7d8c1227497c59786 (patch)
tree1e2b1318f680fffd555ddc26a48e4a4156b06dfc /libtransport/CMakeLists.txt
parentbe54ac541c9700eaa9085bc8b4ee21b7a5f7e30a (diff)
[HICN-488] Adding lock to vapi calls and manage vapi_connect in order to connect only once.
- Added library to hicn-plugin called safe_vapi that takes care of handling concurrent calls to the vapi. - Removed dependency of libhicnctrl from libtransport and added dependency to safe_vapi. - Added dependency to safe_vapi on libhicnctrl Change-Id: Ie49e8319f64a50e7ed6a56e041db977c3b184cc5 Signed-off-by: Alberto Compagno <acompagn+fdio@cisco.com>
Diffstat (limited to 'libtransport/CMakeLists.txt')
-rw-r--r--libtransport/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
index cc302d09a..6c79c9118 100644
--- a/libtransport/CMakeLists.txt
+++ b/libtransport/CMakeLists.txt
@@ -83,11 +83,11 @@ endif()
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
if (__vpp__)
find_package(HicnPlugin REQUIRED)
- find_package(Libhicnctrl REQUIRED)
+ find_package(SafeVapi REQUIRED)
list(APPEND LIBRARIES
${LIBMEMIF_LIBRARIES}
- ${LIBHICNCTRL_SHARED}
+ ${SAFE_VAPI_LIBRARIES}
)
endif()
@@ -107,12 +107,12 @@ else()
if (__vpp__)
list(APPEND DEPENDENCIES
hicn_plugin
- ${LIBHICNCTRL_SHARED}
+ ${SAFE_VAPI_SHARED}
)
- set(LIBHICNCTRL_LIBRARIES ${LIBHICNCTRL_SHARED})
list(APPEND LIBRARIES
${LIBMEMIF_LIBRARIES}
+ ${SAFE_VAPI_LIBRARIES}
)
endif()
endif()
@@ -120,7 +120,7 @@ endif()
list(APPEND LIBTRANSPORT_INTERNAL_INCLUDE_DIRS
${LIBMEMIF_INCLUDE_DIRS}
- ${LIBHICNCTRL_INCLUSE_DIRS}
+ ${SAFE_VAPI_INCLUDE_DIRS}
)
include(Packaging)