summaryrefslogtreecommitdiffstats
path: root/libtransport/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-05-16 15:46:10 +0000
committerGerrit Code Review <gerrit@fd.io>2019-05-16 15:46:10 +0000
commit41ed041613107ae6f1bf9cae5147cfdc71a1ba54 (patch)
treec67e8bcd830e348c0a905fe52d48a248c0031132 /libtransport/CMakeLists.txt
parentdb8d063677b42c0ec8191728e55d1d5efef80822 (diff)
parent5c9b2cd16e76b7d731bd31422b4a555dbeff1541 (diff)
Merge "[HICN-195] Generate static libs for android"
Diffstat (limited to 'libtransport/CMakeLists.txt')
-rw-r--r--libtransport/CMakeLists.txt19
1 files changed, 13 insertions, 6 deletions
diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
index 757521574..d70a837b9 100644
--- a/libtransport/CMakeLists.txt
+++ b/libtransport/CMakeLists.txt
@@ -82,11 +82,18 @@ if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
endif()
set(LIBTRANSPORT hicntransport)
else()
- set(HICN_LIBRARIES ${LIBHICN_SHARED})
- list(APPEND DEPENDENCIES
- ${LIBHICN}
- ${LIBHICN_SHARED}
- )
+ if (ANDROID_API)
+ set(HICN_LIBRARIES ${LIBHICN})
+ list(APPEND DEPENDENCIES
+ ${LIBHICN}
+ )
+ else ()
+ set(HICN_LIBRARIES ${LIBHICN_SHARED})
+ list(APPEND DEPENDENCIES
+ ${LIBHICN}
+ ${LIBHICN_SHARED}
+ )
+ endif ()
if (__vpp__)
list(APPEND DEPENDENCIES
@@ -108,7 +115,7 @@ if (${COMPILE_TESTS})
endif()
if(ANDROID_API)
-find_package(OpenSSL REQUIRED)
+ find_package(OpenSSL REQUIRED)
endif ()
list(APPEND LIBRARIES