aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/src/hicn/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <manangel@cisco.com>2019-03-12 16:16:38 +0100
committerAngelo Mantellini <manangel@cisco.com>2019-03-12 18:04:21 +0100
commita7398701907901dab1af3b415741a526971af4b1 (patch)
tree0bea14dd1715462e6e765a362187f91f9ce0c28f /libtransport/src/hicn/transport/CMakeLists.txt
parent982ef728639113069db6af0b7869afc457853a9b (diff)
[HICN-109] Adding higet application
Change-Id: If558eb5da804fde2ab331a463bf9c9c11cc471e9 Signed-off-by: Angelo Mantellini <manangel@cisco.com>
Diffstat (limited to 'libtransport/src/hicn/transport/CMakeLists.txt')
-rw-r--r--libtransport/src/hicn/transport/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/libtransport/src/hicn/transport/CMakeLists.txt b/libtransport/src/hicn/transport/CMakeLists.txt
index 82d478b65..4314ef908 100644
--- a/libtransport/src/hicn/transport/CMakeLists.txt
+++ b/libtransport/src/hicn/transport/CMakeLists.txt
@@ -15,13 +15,6 @@ cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
set(ASIO_STANDALONE 1)
-configure_file("config.h.in" "config.h" @ONLY)
-install(
- FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h
- DESTINATION include/hicn/transport
- COMPONENT lib${LIBTRANSPORT}-dev
-)
-
add_subdirectory(core)
add_subdirectory(errors)
add_subdirectory(http)
@@ -30,6 +23,13 @@ add_subdirectory(portability)
add_subdirectory(protocols)
add_subdirectory(utils)
+configure_file("config.h.in" "config.h" @ONLY)
+install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h
+ DESTINATION include/hicn/transport
+ COMPONENT lib${LIBTRANSPORT}-dev
+)
+
set (COMPILER_DEFINITIONS "")
list(INSERT LIBTRANSPORT_INCLUDE_DIRS 0