summaryrefslogtreecommitdiffstats
path: root/libtransport/src/hicn/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-07-18 11:17:00 +0000
committerGerrit Code Review <gerrit@fd.io>2019-07-18 11:17:00 +0000
commit5ca4abd6766b75a56172dd71b2ad604fe4c7ff7d (patch)
tree95f08346a82d97f393af5ae27f52ccf1929e6c0a /libtransport/src/hicn/transport/CMakeLists.txt
parentac16674af88636b6016cd90d15d7f6887a1c8b19 (diff)
parent64442da40c3e390649d42e3e97a74986bba27afd (diff)
Merge "[HICN-248] Install libraries under correct folder (lib/x86_64-linux-gnu on ubuntu/debian and lib64 on centos)"
Diffstat (limited to 'libtransport/src/hicn/transport/CMakeLists.txt')
-rw-r--r--libtransport/src/hicn/transport/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/libtransport/src/hicn/transport/CMakeLists.txt b/libtransport/src/hicn/transport/CMakeLists.txt
index b6be3f77a..3b5e9a15f 100644
--- a/libtransport/src/hicn/transport/CMakeLists.txt
+++ b/libtransport/src/hicn/transport/CMakeLists.txt
@@ -13,6 +13,8 @@
cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+include(GNUInstallDirs)
+
set(ASIO_STANDALONE 1)
add_subdirectory(core)
@@ -26,7 +28,7 @@ add_subdirectory(utils)
configure_file("config.h.in" "config.h" @ONLY)
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h
- DESTINATION include/hicn/transport
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hicn/transport
COMPONENT lib${LIBTRANSPORT}-dev
)